This will take you to the main site where there is history, technical information and other information on these cars.
This takes you back to the main page of the forums.
This is the control panel to change your password, information and preferences on this message board.
Click here if your lost your password or need to register on this message board. You must be a registered user to post. Registration is free.
Search this board for information you need.
Click here to buy cool Squarebirds mechandise.
Click here to support Squarebirds.org. For $20 annually receive 20mBytes webspace, a Squarebirds e-mail address and member's icon on the message board.
  #1  
Old 12-03-2016, 11:43 AM
HighwayThunder's Avatar
HighwayThunder HighwayThunder is offline
Apprentice
 
Join Date: Nov 19 2013
Posts: 89
HighwayThunder is on a distinguished road
Default Fuel Pump?

My 390 FE has a hot cam, Street Demon carb. It's been trouble tuning it to optimum. It'd be running fine and then, for no apparent reason, stall. Restarting afterward would be problematic.

Had always thought that this was due to my inexperience in doing a proper tune-up. So I took the car to a shop specializing in performance engines and had them do the tune up.

When I picked the car up it ran better than it ever had before. It drove fine through the surface streets leading to the highway and then ran OK at highway speeds. But after about 10 miles, off the highway in stop-n-go traffic, it stalled again. It would restart but stall when put in gear. After several start-stall iterations, it wouldn't restart. Had to tow it home. The next day I got it started (using some canned starting fluid) and drove it a short distance.

Started it again a few days later. After a full warm up, it idled smoothly for about 5 minutes and then faltered and died.


Would the above description suggest a problem with the stock mechanical fuel pump? Or is there another possible explanation for it?


I compared the specs for the Demon carb and the stock fuel pump. The input fuel pressure range for the carb is slightly higher than the output range of the pump, but the nominal numbers do fall within both ranges. However, the pump is old. Have considered replacing with an electric pump.


Cheers,
__________________
Richard
1966 Thunderbird Hardtop,
390 with Edelbrock heads. Visit my restoration blog at hwythunder.com .
Reply With Quote
  #2  
Old 12-03-2016, 12:01 PM
jopizz's Avatar
jopizz jopizz is online now
Excellent Auto Mechanic for over 40 years.
 
Join Date: Nov 23 2009
Posts: 4,759
jopizz is on a distinguished road
Default

Quote:
Originally Posted by HighwayThunder View Post

I compared the specs for the Demon carb and the stock fuel pump. The input fuel pressure range for the carb is slightly higher than the output range of the pump, but the nominal numbers do fall within both ranges. However, the pump is old. Have considered replacing with an electric pump.


Cheers,
Specs on your stock fuel pump mean nothing. The only way to tell what your pump is putting out is to attach a fuel pressure gauge. You may find out that's it's not putting out anything close to what it's supposed to. Newer fuels and old pumps are a bad combination.

John
__________________
John Pizzi - Squarebirds Administrator
1959 Convertible

Thunderbird Registry #36223
jopizz@verizon.net 856-779-9695

http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm
Reply With Quote
  #3  
Old 12-03-2016, 12:34 PM
pbf777 pbf777 is offline
Experienced
 
Join Date: Jan 9 2016
Posts: 159
pbf777 is on a distinguished road
Default

If you feel your fuel pump, or any portion/component of the fuel delivery system (to the carburetor) is at fault (including vapor lock), inspect the fuel level within the carburetor fuel bowl(s) immediately upon the vehicle's stalling.

Your Demon carburetor is equipped with either a sight glass for viewing or sight screw affixed to the fuel bowl which is removed for inspecting fuel level. Scott.
Reply With Quote
  #4  
Old 12-03-2016, 07:56 PM
Yadkin Yadkin is offline
Banned
 
Join Date: Aug 11 2012
Posts: 1,910
Yadkin is on a distinguished road
Default

I've had a lot of problems with mechanical fuel pumps available from local parts stores. Airtech units are inexpensive, look like OEM, so all the stores carry them, but steer far away from them. Buy a good brand through Summit or another speed shop.

Electric has the advantage of being able to wire to turn on prior to crank, filling your evaporated fuel bowls in the carburetor. But frame mounted pumps are noisy. In tank is the best way to go (I have this setup) but it requires modification of your tank with a large hole on the top and an access hole in the trunk shelf. Tanks Inc makes a bracket that will work, but has to be lengthened by welding. Make sure that you get a low pressure pump (5psi) with your carb setup.
Reply With Quote
  #5  
Old 12-05-2016, 10:50 AM
pbf777 pbf777 is offline
Experienced
 
Join Date: Jan 9 2016
Posts: 159
pbf777 is on a distinguished road
Default

I believe most of the "in-tank" electric fuel pumps will be of the E.F.I. intended application (35-50+ P.S.I.), but this is unimportant, as the resultant working pressure will be dictated by the fuel pressure regulator, which yes, should be set at approximately 5-7 P.S.I. for most carburetor applications, and of the "by-pass" design to reduce laboring the pump needlessly. Scott.
Reply With Quote
  #6  
Old 12-05-2016, 07:02 PM
stubbie stubbie is offline
Experienced
 
Join Date: Jul 7 2011
Posts: 237
stubbie is on a distinguished road
Default

I would look at a Posi Flo facet pump if replacing yours. You can get a 1.5-10psi what they call a fast street version. They make a bit of a ticking noise when turned on but you probably wont hear it once the engine is running.
Reply With Quote
  #7  
Old 01-21-2017, 01:52 PM
HighwayThunder's Avatar
HighwayThunder HighwayThunder is offline
Apprentice
 
Join Date: Nov 19 2013
Posts: 89
HighwayThunder is on a distinguished road
Default Electric Fuel Pump

Following up on the probable fuel pump problem I installed an electric fuel pump. The carburetor manufacturer suggested the Mr. Gasket Model 12S as meeting their flow specs. The new fuel pump solved the problem of erratic engine behavior and sudden stalling.

Here are some pics of the installation.
Attached Images
File Type: jpg FuelPump.jpg (123.8 KB, 105 views)
File Type: jpg FuelPumpBreaker.jpg (112.2 KB, 105 views)
File Type: jpg FuelPumpRelay.jpg (97.5 KB, 105 views)
File Type: jpg FwdFuelFilter.jpg (324.9 KB, 104 views)
__________________
Richard
1966 Thunderbird Hardtop,
390 with Edelbrock heads. Visit my restoration blog at hwythunder.com .
Reply With Quote
  #8  
Old 03-10-2017, 02:51 PM
HighwayThunder's Avatar
HighwayThunder HighwayThunder is offline
Apprentice
 
Join Date: Nov 19 2013
Posts: 89
HighwayThunder is on a distinguished road
Default Still Stalling!

I'm still having a problem with the car stalling for reasons mysterious. The scenario is the same:
  • The car starts.
  • After warm up, it drives great. I drive maybe 5-10 miles. Even in traffic, no problem.
  • I stop, turn the car off for a few minutes.
  • The car starts OK, but idle is suddenly lower than it was. It stalls when put in gear. Even if I give it some gas before putting it in gear, it stalls. Even after an hour or so of cool-down it still stalls. (It behaves like you'd expect it to if it had a vacuum leak, but it doesn't. )
  • I have it towed home
  • The next morning it starts right up and drives great again
Note that the engine does not seem to be overheating. TempGauge stays in the normal range. Nonetheless, I do think that the problem is temperature related.

If I recall correctly, the themostat is 180 degrees. I'm going to replace it with one that flows at 160 degrees. (grasping at straws, here)

Could the carburetor be sensitive to a gradual rise in engine block heat?

I've been trying to figure this out for months. I'm flummoxed.

Cheers,
__________________
Richard
1966 Thunderbird Hardtop,
390 with Edelbrock heads. Visit my restoration blog at hwythunder.com .
Reply With Quote
  #9  
Old 03-10-2017, 03:00 PM
jopizz's Avatar
jopizz jopizz is online now
Excellent Auto Mechanic for over 40 years.
 
Join Date: Nov 23 2009
Posts: 4,759
jopizz is on a distinguished road
Default

What CFM is your carburetor.

John
__________________
John Pizzi - Squarebirds Administrator
1959 Convertible

Thunderbird Registry #36223
jopizz@verizon.net 856-779-9695

http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm
Reply With Quote
  #10  
Old 03-10-2017, 04:08 PM
DKheld's Avatar
DKheld DKheld is offline
Super-Experienced
 
Join Date: Aug 27 2008
Posts: 1,432
DKheld is on a distinguished road
Default

I've had 2 similar problems.

#1
'60 Tbird. Problem was the original gas tank - even though I had the OEM tank boiled and coated. Condensation finally took its toll and I decided to have the OEM tank cleaned and coated (and that tank was in pretty nice shape - car was bought new by my Dad and it's been garage kept all it's life). Replaced the steel line front to back too.
After having that done I also found that the ethanol in today's fuels was destroying the coating and it was coming loose.
Replaced the tank (MQ Products - Canada) and it worked better but still would seem to be starved for fuel at times. 2 new mechanical fuel pumps also. Wound up drilling a tiny hole on the side of the filler neck for air to prevent vapor lock. Before drilling I tried a different cap (vented) but it would let so much air in (and none back out) that the fuel would be pushed past the float needles. At times when I opened the cap it felt like I had 20-25 psi of air pressure in the tank. Since drilling the hole it's been fine. Re-used OEM cap. Drilled the hole on the side of the filler neck to prevent water from entering when washing. Would be just a drop or two but figured if I could prevent it - why not. Tank may rust sooner with the hole in the neck? All I really care about is that it works now and no more tow bills.

#2
'57 MGA These have a low pressure SU electric pump. Pretty much the same symptoms - turned out to be the coil. Would heat up and break down then work fine after cooling back off. Took a while to find that - never suspected ignition - always seemed to have good enough spark. Thought it was the carbs or fuel pump because I had rebuilt them. Shudda' known I do good work and it was something else.


Sounds a lot like my coil problem...
Eric

Last edited by DKheld : 03-10-2017 at 04:18 PM.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:14 PM.

Driving, racing or working on cars can be hazardous. The procedures and advice on this website including the message board are opinion only. Squarebirds.org and its webmasters and contributors do not guarantee the correctness of the advice and procedures. The Squarebirds.org and its webmasters assume no liability for any damage, fines, punishment, injury or death resulting from following these procedures or advice. If you do not have the skills or tools to repair your car, please consult a professional. By using this site you agree to hold harmless the Squarebirds.org, its authors and its webmasters from any resulting claim and costs that may occur from using the information found on this site.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Any submissions to this site and any post on this site becomes property of Squarebirds.org . The webmasters reserve the right to edit and modify any submissions to this site. All material on this is site is copyrighted by the Squarebirds.org. Reproduction by any means other than for personal use is strictly prohibited. Permission to use material on this site can be obtained by contacting the webmasters. Copyright 2002-2016 by Squarebirds.org.